Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 29 Nov 2002 08:01:10 -0500
From:      Mike Tancsa <mike@sentex.net>
To:        "Peter Brezny" <peter@skyrunner.net>
Cc:        freebsd-isp@freebsd.org
Subject:   Re: Freebsd as vlan trunk controller.
Message-ID:  <vooeuuci0m0pvm72lm851mu6l6igeqiltt@4ax.com>
In-Reply-To: <mailman.1038541083.29033.fisp-l@lists.sentex.ca>
References:  <20021128195559.I82419-100000@lethargic.dyndns.org> <mailman.1038541083.29033.fisp-l@lists.sentex.ca>

next in thread | previous in thread | raw e-mail | index | archive | help


There have been many examples of this posted to the various FreeBSD =
lists.
a quick search via google groups should bring up further examples and
discussions.  While other cards supposedly work, I only have experience
with the fxp (intel) cards.


e.g. on the cisco side,

interface FastEthernet0/2
 description accounting network
 duplex full
 speed 100
 switchport access vlan 151
 no cdp enable

interface FastEthernet0/3
 description the 192.168.135.0/24 network
 duplex full
 speed 100
 switchport access vlan 100
 no cdp enable

interface FastEthernet0/4
 description trunk to my FreeBSD box
 duplex full
 speed 100
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,80,81,92,95,98,100,102-160,1000-1005
 switchport mode trunk
 no cdp enable


On the FreeBSD side fxp0 is plugged into fa0/4

#10.255.255.254 is an address not used anywhere in our network
ifconfig fxp0 10.255.255.254 netmask 255.255.255.255 media 100baseTX
mediaopt full-duplex

#this will join the vlan/collision domain on port fa0/3
/sbin/ifconfig vlan0 192.168.135.202 netmask 255.255.255.240 vlan 100
vlandev fxp0 mtu 1500 up

#if we defined only 1 vlan in the kernel, lets clone/create a new
#interface via the create command
#join the accounting vlan on fa0/2
ifconfig vlan1 create
/sbin/ifconfig vlan1 192.168.199.1 netmask 255.255.255.240 vlan 151 =
vlandev
fxp0 mtu 1500 up


	---Mike

On Thu, 28 Nov 2002 22:35:50 -0500, in sentex.lists.freebsd.isp you =
wrote:

>Jason,
>I had a typo, it's a 2924m-xl
>
>Thanks for the tips however...
>
>My main problem here is that I don't really know what I'm talking about.
>I'm just now looking into configuring vlans with freebsd and literally =
know
>very little more than about a half hours flip through the man pages.
>
>I want a freebsd box with 2 fast Ethernet adapters to act as a router, =
and
>instead of putting several multiport cards into that box, I want one of =
the
>fast Ethernet adapters to go into a switch, which will have vlans.  I =
want
>the bsd system to send the traffic to the appropriate vlan, so that if I
>desire, I could have the equivalent of 24 nic's in one freebsd box.
>
>I believe what I am after is something that can handle the 802.1q
>
>Any help on clearing up terminology and pointers to good hardware to =
use,
>whether or not this Cisco 2924m-xl or another Cisco 1900.
>
>I've got a lot of reading to do, i've only scraped the tip of the =
iceburg.
>Any tips would be appreciated.
>
>
>Peter Brezny
>Skyrunner.net
>
>
>-----Original Message-----
>From: Jason Hunt [mailto:leth@primus.ca]
>Sent: Thursday, November 28, 2002 8:23 PM
>To: Peter Brezny
>Cc: freebsd-isp@FreeBSD.ORG
>Subject: Re: Freebsd as vlan trunk controller.
>
>
>On Thu, 28 Nov 2002, Peter Brezny wrote:
>
>> I'm looking for pointers/tips/stories on configuring freebsd for use =
as a
>> vlan trunk controller for connecting to a cisco 2624 switch.
>>
>> Any pointers to docs/how to's or personal experience is appreciated.
>>
>
>Are you referring to the VLAN Trunking Protocol?  If so, then from what =
I
>can tell, the 2624 does not support VTP.  It doesn't even seem to =
support
>actual VLAN tagging.  (And, if it supports one it should support the
>other.)  Instead, this switch just allows you to create multiple =
broadcast
>domains within itself, not actual VLANs.
>
>Also, I think you might be referring to doing a "router on a stick"
>configuration.  That is, every VLAN can talk to a single port.  This
>requires the NIC support either ISL (Inter-Switch Links) or 802.1Q
>trunking.  As far as that goes, I've not looked into anything like that
>before.
>
>
>-----Original Message-----
>From: Jason Hunt [mailto:leth@primus.ca]
>Sent: Thursday, November 28, 2002 8:23 PM
>To: Peter Brezny
>Cc: freebsd-isp@FreeBSD.ORG
>Subject: Re: Freebsd as vlan trunk controller.
>
>
>On Thu, 28 Nov 2002, Peter Brezny wrote:
>
>> I'm looking for pointers/tips/stories on configuring freebsd for use =
as a
>> vlan trunk controller for connecting to a cisco 2624 switch.
>>
>> Any pointers to docs/how to's or personal experience is appreciated.
>>
>
>Are you referring to the VLAN Trunking Protocol?  If so, then from what =
I
>can tell, the 2624 does not support VTP.  It doesn't even seem to =
support
>actual VLAN tagging.  (And, if it supports one it should support the
>other.)  Instead, this switch just allows you to create multiple =
broadcast
>domains within itself, not actual VLANs.
>
>Also, I think you might be referring to doing a "router on a stick"
>configuration.  That is, every VLAN can talk to a single port.  This
>requires the NIC support either ISL (Inter-Switch Links) or 802.1Q
>trunking.  As far as that goes, I've not looked into anything like that
>before.
>
>
>
>
>To Unsubscribe: send mail to majordomo@FreeBSD.org
>with "unsubscribe freebsd-isp" in the body of the message

Mike Tancsa  (mike@sentex.net)=09
http://www.sentex.net/mike

To Unsubscribe: send mail to majordomo@FreeBSD.org
with "unsubscribe freebsd-isp" in the body of the message




Want to link to this message? Use this URL: <https://mail-archive.FreeBSD.org/cgi/mid.cgi?vooeuuci0m0pvm72lm851mu6l6igeqiltt>