Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 28 Dec 2009 10:47:04 +0000 (UTC)
From:      Luigi Rizzo <luigi@FreeBSD.org>
To:        cvs-src-old@freebsd.org
Subject:   cvs commit: src/sys/net if_bridge.c if_ethersubr.c src/sys/netgraph ng_ipfw.c ng_ipfw.h src/sys/netinet in.h ip_dummynet.h src/sys/netinet/ipfw ip_dummynet.c ip_fw2.c ip_fw_dynamic.c ip_fw_log.c ip_fw_nat.c ip_fw_pfil.c ...
Message-ID:  <200912281047.nBSAlrLU064514@repoman.freebsd.org>

next in thread | raw e-mail | index | archive | help
luigi       2009-12-28 10:47:04 UTC

  FreeBSD src repository

  Modified files:
    sys/net              if_bridge.c if_ethersubr.c 
    sys/netgraph         ng_ipfw.c ng_ipfw.h 
    sys/netinet          in.h ip_dummynet.h 
    sys/netinet/ipfw     ip_dummynet.c ip_fw2.c ip_fw_dynamic.c 
                         ip_fw_log.c ip_fw_nat.c ip_fw_pfil.c 
                         ip_fw_private.h ip_fw_sockopt.c 
  Log:
  SVN rev 201122 on 2009-12-28 10:47:04Z by luigi
  
  bring in several cleanups tested in ipfw3-head branch, namely:
  
  r201011
  - move most of ng_ipfw.h into ip_fw_private.h, as this code is
    ipfw-specific. This removes a dependency on ng_ipfw.h from some files.
  
  - move many equivalent definitions of direction (IN, OUT) for
    reinjected packets into ip_fw_private.h
  
  - document the structure of the packet tags used for dummynet
    and netgraph;
  
  r201049
  - merge some common code to attach/detach hooks into
    a single function.
  
  r201055
  - remove some duplicated code in ip_fw_pfil. The input
    and output processing uses almost exactly the same code so
    there is no need to use two separate hooks.
    ip_fw_pfil.o goes from 2096 to 1382 bytes of .text
  
  r201057 (see the svn log for full details)
  - macros to make the conversion of ip_len and ip_off
    between host and network format more explicit
  
  r201113 (the remaining parts)
  - readability fixes -- put braces around some large for() blocks,
    localize variables so the compiler does not think they are uninitialized,
    do not insist on precise allocation size if we have more than we need.
  
  r201119
  - when doing a lookup, keys must be in big endian format because
    this is what the radix code expects (this fixes a bug in the
    recently-introduced 'lookup' option)
  
  No ABI changes in this commit.
  
  MFC after:      1 week
  
  Revision  Changes    Path
  1.136     +8 -4      src/sys/net/if_bridge.c
  1.274     +10 -5     src/sys/net/if_ethersubr.c
  1.15      +3 -3      src/sys/netgraph/ng_ipfw.c
  1.5       +3 -23     src/sys/netgraph/ng_ipfw.h
  1.114     +26 -0     src/sys/netinet/in.h
  1.49      +6 -25     src/sys/netinet/ip_dummynet.h
  1.17      +26 -26    src/sys/netinet/ipfw/ip_dummynet.c
  1.36      +46 -41    src/sys/netinet/ipfw/ip_fw2.c
  1.4       +4 -0      src/sys/netinet/ipfw/ip_fw_dynamic.c
  1.5       +18 -9     src/sys/netinet/ipfw/ip_fw_log.c
  1.11      +4 -12     src/sys/netinet/ipfw/ip_fw_nat.c
  1.10      +142 -333  src/sys/netinet/ipfw/ip_fw_pfil.c
  1.7       +46 -10    src/sys/netinet/ipfw/ip_fw_private.h
  1.8       +0 -2      src/sys/netinet/ipfw/ip_fw_sockopt.c



Want to link to this message? Use this URL: <https://mail-archive.FreeBSD.org/cgi/mid.cgi?200912281047.nBSAlrLU064514>