Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 20 Jul 2002 21:48:05 -0400
From:      Mike Tancsa <mike@sentex.net>
To:        shubha mr <shubha_mr@yahoo.com>
Cc:        freebsd-net@freebsd.org
Subject:   Re: VLAN - testing-urgent!
Message-ID:  <p64kju80cgl0e21p777bhue1einoqskrkq@4ax.com>
In-Reply-To: <20020719054804.78353.qmail@web14609.mail.yahoo.com>
References:  <20020719054804.78353.qmail@web14609.mail.yahoo.com>

next in thread | previous in thread | raw e-mail | index | archive | help

quick example...

Use a NIC that is vlan capable. e.g. fxp is very good. Get a 802.1q VLAN
capable switch (e.g. a cisco 29xx)

in port 1 plug in your fxp card

On the Cisco (IP address 10.1.1.2 netmask 255.255.255.252), do something
like

interface FastEthernet0/1
 description vlan trunking port
 duplex full
 speed 100
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,101
 switchport mode trunk


interface FastEthernet0/2
 description the-192-network
 switchport access vlan 100


interface FastEthernet0/3
 description the-17-network
 switchport access vlan 101



On the FreeBSD box (with a kernel entry of pseudo-device   vlan    1)   =20

ifconfig fxp0 10.1.1.1 netmask 255.255.255.252 media 100baseTX mediaopt
full-duplex


ifconfig vlan0 192.168.1.1 netmask 255.255.255.0 vlan 100 vlandev fxp0 =
mtu
1500 up
ifconfig vlan1 create
ifconfig vlan1 172.16.1.1 netmask 255.255.255.0 vlan 101 vlandev fxp0 mtu
1500 up


	---Mike


On Fri, 19 Jul 2002 06:48:04 +0100 (BST), in sentex.lists.freebsd.net you
wrote:

>Hi,
>Would like to know how to test VLAN for ethernet
>network driver for a NIC.
>
>Thanks a lot
>shubha
>
>__________________________________________________
>Do You Yahoo!?
>Yahoo! Autos - Get free new car price quotes
>http://autos.yahoo.com
>
>To Unsubscribe: send mail to majordomo@FreeBSD.org
>with "unsubscribe freebsd-net" in the body of the message

Mike Tancsa  (mdtancsa@sentex.net)	=09
Sentex Communications Corp,   	=09
Waterloo, Ontario, Canada
"Given enough time, 100 monkeys on 100 routers=20
could setup a national IP network." (KDW2)

To Unsubscribe: send mail to majordomo@FreeBSD.org
with "unsubscribe freebsd-net" in the body of the message




Want to link to this message? Use this URL: <https://mail-archive.FreeBSD.org/cgi/mid.cgi?p64kju80cgl0e21p777bhue1einoqskrkq>