Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 1 Mar 2004 14:37:02 -0800 (PST)
From:      Robert Watson <rwatson@FreeBSD.org>
To:        src-committers@FreeBSD.org, cvs-src@FreeBSD.org, cvs-all@FreeBSD.org
Subject:   cvs commit: src/sys/sys mutex.h src/sys/netinet ip_input.c
Message-ID:  <200403012237.i21Mb2es091556@repoman.freebsd.org>

next in thread | raw e-mail | index | archive | help
rwatson     2004/03/01 14:37:02 PST

  FreeBSD src repository

  Modified files:
    sys/sys              mutex.h 
    sys/netinet          ip_input.c 
  Log:
  Rename NET_PICKUP_GIANT() to NET_LOCK_GIANT(), and NET_DROP_GIANT()
  to NET_UNLOCK_GIANT().  While they are used in similar ways, the
  semantics are quite different -- NET_LOCK_GIANT() and NET_UNLOCK_GIANT()
  directly wrap mutex lock and unlock operations, whereas drop/pickup
  special case the handling of Giant recursion.  Add a comment saying
  as much.
  
  Add NET_ASSERT_GIANT(), which conditionally asserts Giant based
  on the value of debug_mpsafenet.
  
  Revision  Changes    Path
  1.266     +2 -2      src/sys/netinet/ip_input.c
  1.69      +10 -4     src/sys/sys/mutex.h



Want to link to this message? Use this URL: <https://mail-archive.FreeBSD.org/cgi/mid.cgi?200403012237.i21Mb2es091556>