From owner-freebsd-arch Wed Mar 13 20:59:51 2002 Delivered-To: freebsd-arch@freebsd.org Received: from mail.rpi.edu (mail.rpi.edu [128.113.22.40]) by hub.freebsd.org (Postfix) with ESMTP id 7BAE137B417 for ; Wed, 13 Mar 2002 20:59:49 -0800 (PST) Received: from [128.113.24.47] (gilead.acs.rpi.edu [128.113.24.47]) by mail.rpi.edu (8.12.1/8.12.1) with ESMTP id g2E4xlWZ076674; Wed, 13 Mar 2002 23:59:47 -0500 Mime-Version: 1.0 X-Sender: drosih@mail.rpi.edu Message-Id: In-Reply-To: <20020313.211252.132928159.imp@village.org> References: <20020313.211252.132928159.imp@village.org> Date: Wed, 13 Mar 2002 23:59:46 -0500 To: "M. Warner Losh" , arch@FreeBSD.ORG From: Garance A Drosihn Subject: Re: Comments on sys.mk change to make /etc/make.conf optional Content-Type: text/plain; charset="us-ascii" ; format="flowed" X-Scanned-By: MIMEDefang 2.3 (www dot roaringpenguin dot com slash mimedefang) Sender: owner-freebsd-arch@FreeBSD.ORG Precedence: bulk List-ID: List-Archive: (Web Archive) List-Help: (List Instructions) List-Subscribe: List-Unsubscribe: X-Loop: FreeBSD.ORG At 9:12 PM -0700 3/13/02, M. Warner Losh wrote: >I'm posting this here because it is a fairly fundamental change >to the system. It makes /etc/make.conf optional, for shared >environments that might want to have different settings for >different users. I used __MAKE_CONF to try not to pollute things. I like the idea. I would prefer a different name for the variable. Something without the leading __ , because to me the leading underscores would imply a name that a user would *not* define. BSD_MAKE_CONF ? FBSD_MAKE_CONF ? -- Garance Alistair Drosehn = gad@eclipse.acs.rpi.edu Senior Systems Programmer or gad@freebsd.org Rensselaer Polytechnic Institute or drosih@rpi.edu To Unsubscribe: send mail to majordomo@FreeBSD.org with "unsubscribe freebsd-arch" in the body of the message