From owner-svn-src-head@freebsd.org Mon Jun 29 20:30:04 2020 Return-Path: Delivered-To: svn-src-head@mailman.nyi.freebsd.org Received: from mx1.freebsd.org (mx1.freebsd.org [IPv6:2610:1c1:1:606c::19:1]) by mailman.nyi.freebsd.org (Postfix) with ESMTP id 6AEAD353FF0; Mon, 29 Jun 2020 20:30:04 +0000 (UTC) (envelope-from rpokala@freebsd.org) Received: from smtp.freebsd.org (smtp.freebsd.org [96.47.72.83]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (4096 bits) server-digest SHA256 client-signature RSA-PSS (4096 bits) client-digest SHA256) (Client CN "smtp.freebsd.org", Issuer "Let's Encrypt Authority X3" (verified OK)) by mx1.freebsd.org (Postfix) with ESMTPS id 49wfHc25XQz4MNP; Mon, 29 Jun 2020 20:30:04 +0000 (UTC) (envelope-from rpokala@freebsd.org) Received: from [172.17.133.71] (unknown [12.202.168.51]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (Client did not present a certificate) (Authenticated sender: rpokala) by smtp.freebsd.org (Postfix) with ESMTPSA id 63CA619F7E; Mon, 29 Jun 2020 20:30:03 +0000 (UTC) (envelope-from rpokala@freebsd.org) User-Agent: Microsoft-MacOutlook/16.38.20061401 Date: Mon, 29 Jun 2020 13:30:00 -0700 Subject: Re: svn commit: r362781 - head/sys/compat/linuxkpi/common/include/linux From: Ravi Pokala To: Warner Losh , Ravi Pokala CC: Hans Petter Selasky , src-committers , , Message-ID: Thread-Topic: svn commit: r362781 - head/sys/compat/linuxkpi/common/include/linux References: <202006291308.05TD8eTP014019@repo.freebsd.org> In-Reply-To: Mime-version: 1.0 Content-Type: text/plain; charset="UTF-8" Content-Transfer-Encoding: 7bit X-Content-Filtered-By: Mailman/MimeDel 2.1.33 X-BeenThere: svn-src-head@freebsd.org X-Mailman-Version: 2.1.33 Precedence: list List-Id: SVN commit messages for the src tree for head/-current List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Mon, 29 Jun 2020 20:30:04 -0000 From: on behalf of Warner Losh Date: 2020-06-29, Monday at 13:26 To: Ravi Pokala Cc: Hans Petter Selasky , src-committers , , Subject: Re: svn commit: r362781 - head/sys/compat/linuxkpi/common/include/linux On Mon, Jun 29, 2020, 2:15 PM Ravi Pokala wrote: -----Original Message----- From: on behalf of Hans Petter Selasky Date: 2020-06-29, Monday at 06:08 To: , , Subject: svn commit: r362781 - head/sys/compat/linuxkpi/common/include/linux Author: hselasky Date: Mon Jun 29 13:08:40 2020 New Revision: 362781 URL: https://svnweb.freebsd.org/changeset/base/362781 Log: Implement is_signed(), type_max() and type_min() function macros in the LinuxKPI. MFC after: 1 week Sponsored by: Mellanox Technologies Modified: head/sys/compat/linuxkpi/common/include/linux/kernel.h Modified: head/sys/compat/linuxkpi/common/include/linux/kernel.h ============================================================================== --- head/sys/compat/linuxkpi/common/include/linux/kernel.h Mon Jun 29 12:59:09 2020 (r362780) +++ head/sys/compat/linuxkpi/common/include/linux/kernel.h Mon Jun 29 13:08:40 2020 (r362781) @@ -564,4 +564,20 @@ linux_ratelimited(linux_ratelimit_t *rl) #define __is_constexpr(x) \ __builtin_constant_p(x) Hi Hans, +#define is_signed(x) (((x)-1 / (x)2) == (x)0) It took me several reads to understand this, until I figured out that 'x' is not a variable, it's the name of a *type*. If 'x' is a variable, then '(x)-1' is subtraction, but '(x)2' and '(x)0' are nonsensical. If 'x' is a *type*, then '(x)-1' is typecasting '-1', and similarly for '(x)2' and '(x)0'. So, perhaps a comment, or a better name for 'x'? I had similar thoughts. Maybe 't' instead? Letters are cheap now, Warner; we can afford to spell out "type". :-) -Ravi (rpokala@) Warner Thanks, Ravi (rpokala@) +#define type_max(x) ( \ + (sizeof(x) >= 8) ? (is_signed(x) ? INT64_MAX : UINT64_MAX) : \ + (sizeof(x) >= 4) ? (is_signed(x) ? INT32_MAX : UINT32_MAX) : \ + (sizeof(x) >= 2) ? (is_signed(x) ? INT16_MAX : UINT16_MAX) : \ + (is_signed(x) ? INT8_MAX : UINT8_MAX) \ +) + +#define type_min(x) ( \ + (sizeof(x) >= 8) ? (is_signed(x) ? INT64_MIN : 0) : \ + (sizeof(x) >= 4) ? (is_signed(x) ? INT32_MIN : 0) : \ + (sizeof(x) >= 2) ? (is_signed(x) ? INT16_MIN : 0) : \ + (is_signed(x) ? INT8_MIN : 0) \ +) + #endif /* _LINUX_KERNEL_H_ */