From owner-cvs-all Thu Feb 22 7:54:30 2001 Delivered-To: cvs-all@freebsd.org Received: from meow.osd.bsdi.com (meow.osd.bsdi.com [204.216.28.88]) by hub.freebsd.org (Postfix) with ESMTP id 072F537B69B; Thu, 22 Feb 2001 07:54:24 -0800 (PST) (envelope-from jhb@FreeBSD.org) Received: from laptop.baldwin.cx (john@jhb-laptop.osd.bsdi.com [204.216.28.241]) by meow.osd.bsdi.com (8.11.2/8.11.2) with ESMTP id f1MFq5l92533; Thu, 22 Feb 2001 07:52:05 -0800 (PST) (envelope-from jhb@FreeBSD.org) Message-ID: X-Mailer: XFMail 1.4.0 on FreeBSD X-Priority: 3 (Normal) Content-Type: text/plain; charset=us-ascii Content-Transfer-Encoding: 8bit MIME-Version: 1.0 In-Reply-To: Date: Thu, 22 Feb 2001 07:54:03 -0800 (PST) From: John Baldwin To: Doug Rabson Subject: Re: cvs commit: src/sys/alpha/alpha swtch.s Cc: cvs-all@FreeBSD.org, cvs-committers@FreeBSD.org Sender: owner-cvs-all@FreeBSD.ORG Precedence: bulk X-Loop: FreeBSD.ORG On 22-Feb-01 Doug Rabson wrote: > On Thu, 22 Feb 2001, John Baldwin wrote: > >> jhb 2001/02/22 07:06:20 PST >> >> Modified files: >> sys/alpha/alpha swtch.s >> Log: >> Cleanup and clarify the comments above switch_trampoline(). > > Should we unify the name for this thing? Alpha and ia64 use > switch_trampoline (derived from the NetBSD/alpha code) and i386 uses > fork_trampoline, which is probably a slightly better name. I've thought about doing that, yes. If you want, I can stick it on my todo list. Also, I have managed to make userret() and ast() (modulo a few commits coming up in the next 15 minutes or so) the same across all architectures. Do you think that given that it would be feasible to move those two functions to sys/kern/subr_trap.c and let them be MI? Also, as a sidenote, I think that addupc_task() should take a uniptr_t, not a uint64_t as its second argument.. -- John Baldwin -- http://www.FreeBSD.org/~jhb/ PGP Key: http://www.baldwin.cx/~john/pgpkey.asc "Power Users Use the Power to Serve!" - http://www.FreeBSD.org/ To Unsubscribe: send mail to majordomo@FreeBSD.org with "unsubscribe cvs-all" in the body of the message