Date: Tue, 25 Aug 1998 19:10:48 +0100 (BST) From: Doug Rabson <dfr@nlsystems.com> To: Stephen McKay <syssgm@dtir.qld.gov.au> Cc: "John S. Dyson" <dyson@iquest.net>, freebsd-current@FreeBSD.ORG Subject: Re: Serious bug in vm_page.h in current Message-ID: <Pine.BSF.4.01.9808251908210.17263-100000@herring.nlsystems.com> In-Reply-To: <199808251210.WAA12649@nymph.dtir.qld.gov.au>
next in thread | previous in thread | raw e-mail | index | archive | help
On Tue, 25 Aug 1998, Stephen McKay wrote: > On Tuesday, 25th August 1998, Doug Rabson wrote: > > >I understand now after reading an old version of your VM patch. I added > >the macro PAGE_BUSY to encapsulate manipulations of m->busy and you added > >PAGE_BUSY to set the PG_BUSY bit. I think we need two macros :-). I don't > >mind changing the m->busy++ one; what do you think is the right name? > > Purely on naming now, the new inline vm_object_set_flag() and friends are > well named. The PAGE_BUSY and PAGE_WAKEUP macros, etc, should be similarly > named inline functions. For example, vm_page_busy_add() and vm_page_wakeup(). > > Best of all, of course, would be to have different names for these two > types of busy-ness (busy the count vs PG_BUSY the flag). John tells us > that m->busy is an "active IO count". It should be named thus. Then > PG_BUSY will no longer be confused with it. I chose the PAGE_XXX type names since they seemed to follow the existing macros in vm_page.h. I am perfectly happy to change them to inline functions with a similar naming convention to the ones in vm_object as long as all of the other PAGE_XXX macros change at the same time. The i/o count should certainly have a less confusing name. -- Doug Rabson Mail: dfr@nlsystems.com Nonlinear Systems Ltd. Phone: +44 181 951 1891 Fax: +44 181 381 1039 To Unsubscribe: send mail to majordomo@FreeBSD.org with "unsubscribe freebsd-current" in the body of the message
Want to link to this message? Use this URL: <https://mail-archive.FreeBSD.org/cgi/mid.cgi?Pine.BSF.4.01.9808251908210.17263-100000>